介绍。

本页将指导您在64 位操作系统的 Raspberry Pi 4 上安装PyTorch 1.11.0或更早版本、TorchVisionLibTorchCaffe2 。

PyTorch 是专门为深度学习开发的软件库。它消耗了大量的 Pi 资源。您可以在 Raspberry Pi 4 上运行 PyTorch,但不要期待奇迹。它运行你的模型,如果不是太复杂的话,但它不能训练新模型。它也不能执行所谓的迁移学习。

PyTorch 在 Python 上运行。有可用的 C++ API,但我们尚未对其进行测试。如果您希望您的 PyTorch 模型在您的 Raspberry Pi 上快速运行,请考虑将您的模型导出到 ONNX。保存为 ONNX 模型后,您可以将其导入 ARM 友好的 C++ 框架,例如 ncnn 或 MNN。它将大大加快您的模型。
如果您的 Raspberry Pi 上有 Ubuntu,则Ubuntu 18.0420.04有特殊的编译轮。

提示。


我们经常会遇到这样的问题,如果我们有一个带有预装框架和深度学习示例的 Raspberry Pi 4 的 SD 图像
我们很高兴遵守这一要求。请在我们的GitHub页面上找到专门用于深度学习的完整可用的 Raspberry Pi 4。从我们的 GDrive 站点下载 zip 文件,解压缩并将图像闪存到 16 GB SD 卡上,然后尽情享受吧!
我们只有 Raspberry Pi 64 位操作系统的指南。随着 PyTorch 的发展,在简单的 32 位机器上构建它变得越来越困难。例如,JIT 跟踪
不适用于 32 位操作系统。
此外,今天我们的大多数访问者在他们的 Raspberry Pi 上使用 64 位操作系统来构建他们的深度学习模型,因为它更快、更健壮。
 我们讨论了两种安装,一种带有 Python 3 wheel
。另一种方法是从头开始构建。不幸的是,没有可用于 Raspberry Pi 4 的官方 pip3 wheel
。但是,为了您的方便,我们创建了这些轮并将它们放在GitHub 上。

版本检查。

在 Raspberry 64 位操作系统上安装 PyTorch 之前,请检查您的操作系统。运行命令 uname -a 并使用下面的屏幕转储验证您的版本。

您还需要使用命令gcc -v检查您的 C++ 编译器版本。它还必须是aarch64-linux-gnu版本,如屏幕截图所示。如果您有 64 位操作系统,但您的 gcc 版本与上面给出的不同,请使用最新版本重新安装整个操作系统。该指南可在此处找到:在 Raspberry Pi 4 上安装 64 位操作系统。因为我们要构建库,所以需要一个 64 位 C++ 编译器。即使你使用 Python 轮子,gcc 也会在幕后被调用。

同样重要的是,根据我们的说明安装后的 zram 交换大小超过 3 GB。只要您不从头开始构建 PyTorch,Less 就没有问题。

wheel安装

PyTorch 由 Ninja 构建。完成整个构建大约需要 3 个小时。我们已经在我们的 GitHub 页面上发布了这些wheel。随意使用这些。完成所有繁琐的工作后,现在只需几分钟即可在 Nano 上安装 PyTorch。对于顽固分子,完整的程序将在本手册后面介绍。
整个过程如下。wheel太大,无法在 GitHub 上存储,因此使用了 Google 驱动器。请确保您安装了最新的 pip3 和 python3 版本,否则 pip 可能会出现消息“ .whl is not a supported wheel on this platform ”。

Python检查。

检查您的 Python3 版本。每个版本都需要一个独特的wheel。树莓派 64 位操作系统使用 Python 3.7.3。所以需要下载torch-1.XY- cp37 - cp37m -linux_aarch64.whl。如果你有最新的 Raspberry Pi Bullseye OS,你的 Python 版本是 3.9.2。
毫无疑问,Python 版本会随着时间的推移而升级,您将需要一个不同的轮子。查看所有wheel的GitHub 页面

PyTorch1.11.0版本安装

# get a fresh start
sudo apt-get update
sudo apt-get upgrade
#install the dependencies (if not already onboard)
sudo apt-get install python3-pip libjpeg-dev libopenblas-dev libopenmpi-dev libomp-dev
#above 58.3.0 you get version issues
sudo -H pip3 install setuptools==58.3.0
sudo -H pip3 install Cython
#install gdown to download from Google drive
sudo -H pip3 install gdown

Buster OS
#download the wheel
gdown https://drive.google.com/uc?id=1gAxP9q94pMeHQ1XOvLHqjEcmgyxjlY_R
# install PyTorch 1.11.0
sudo -H pip3 install torch-1.11.0a0+gitbc2c6ed-cp37-cp37m-linux_aarch64.whl
# clean up
rm torch-1.11.0a0+gitbc2c6ed-cp37-cp37m-linux_aarch64.whl

or Bullseye OS
# download the wheel
gdown https://drive.google.com/uc?id=1ilCdwQX7bq72OW2WF26Og90OpqFX5g_-
# install PyTorch 1.11.0
sudo -H pip3 install torch-1.11.0a0+gitbc2c6ed-cp39-cp39-linux_aarch64.whl
# clean up
rm torch-1.11.0a0+gitbc2c6ed-cp39-cp39-linux_aarch64.whl

PyTorch1.10.0版本安装

# get a fresh start
sudo apt-get update
sudo apt-get upgrade
# install the dependencies (if not already onboard)
sudo apt-get install python3-pip libjpeg-dev libopenblas-dev libopenmpi-dev libomp-dev
# above 58.3.0 you get version issues
sudo -H pip3 install setuptools==58.3.0
sudo -H pip3 install Cython
# install gdown to download from Google drive
sudo -H pip3 install gdown

Buster OS
# download the wheel
gdown https://drive.google.com/uc?id=1y-X1UGC43xUfnycJcuDp7tlyFi8QHxvs
# install PyTorch 1.10.0
sudo -H pip3 install torch-1.10.0a0+git36449ea-cp37-cp37m-linux_aarch64.whl
# clean up
rm torch-1.10.0a0+git36449ea-cp37-cp37m-linux_aarch64.whl

or Bullseye OS
# download the wheel
gdown https://drive.google.com/uc?id=10zJmU1f7PoxN8ARZol4mtbwok4G23XKZ
# install PyTorch 1.10.0
sudo -H pip3 install torch-1.10.0a0+git36449ea-cp39-cp39-linux_aarch64.whl
# clean up
rm torch-1.10.0a0+git36449ea-cp39-cp39-linux_aarch64.whl

PyTorch1.9.0版本安装

# get a fresh start
sudo apt-get update
sudo apt-get upgrade
# install the dependencies (if not already onboard)
sudo apt-get install python3-pip libjpeg-dev libopenblas-dev libopenmpi-dev libomp-dev
# above 58.3.0 you get version issues
sudo -H pip3 install setuptools==58.3.0
sudo -H pip3 install Cython
# install gdown to download from Google drive
sudo -H pip3 install gdown

Buster OS
# download the wheel
gdown https://drive.google.com/uc?id=18KztAf3W_kqFYP2f9uqLj3HBdhoMvVe4
# install PyTorch 1.9.0
sudo -H pip3 install torch-1.9.0a0+gitd69c22d-cp37-cp37m-linux_aarch64.whl
# clean up
rm torch-1.9.0a0+gitd69c22d-cp37-cp37m-linux_aarch64.whl

or Bullseye OS
# download the wheel
gdown https://drive.google.com/uc?id=1p9Sp5YmCJwIkmQIWkpuIkE4NgeYPOr-U
# install PyTorch 1.9.0
sudo -H pip3 install torch-1.9.0a0+gitd69c22d-cp39-cp39-linux_aarch64.whl
# clean up
rm torch-1.9.0a0+gitd69c22d-cp39-cp39-linux_aarch64.whl

成功安装后,您可以使用以下命令检查 PyTorch。